Person and Company Enrich API Outage
Incident Report for People Data Labs
Resolved
This incident has been resolved.
Posted Aug 16, 2023 - 12:25 PDT
Update
The issue causing degraded performance has been resolved and we are continuing to monitor.
Posted Aug 16, 2023 - 12:01 PDT
Update
The issue with erroneous 404s has been resolved but we are seeing higher latency on response times. We are working on resolving this issue and hope to have complete restoration of services shortly.
Posted Aug 16, 2023 - 11:24 PDT
Update
500 errors have been resolved, but Enrich endpoints are experiencing abnormally high 404s. We are working on resolving this issue.
Posted Aug 16, 2023 - 11:08 PDT
Update
We are continuing to monitor for any further issues.
Posted Aug 16, 2023 - 11:01 PDT
Monitoring
A fix is in place and the API is now responding normally. We are continuing to monitor the situation.
Posted Aug 16, 2023 - 11:00 PDT
Update
A change to a backend component is causing Company/Person/Bulk Enrich endpoints to return 500s. We are remediating the issue currently.
Posted Aug 16, 2023 - 10:22 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 16, 2023 - 10:18 PDT
This incident affected: Person Enrichment API, Person Bulk Enrichment API, and Company Enrichment API.