PDL API Endpoints Elevated Error Rate

Incident Report for People Data Labs

Resolved

During the night from ~10:28pm PST to ~3:45am PST we had an outage of our location cleaning app, which caused disruption to the Person / Company Enrichment APIs, the Identify API, and a total outage of the Location Cleaner Endpoint. We've got the issue remediated now and are monitoring in case of further disruption.
Posted Sep 11, 2025 - 06:23 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 11, 2025 - 03:38 PDT

Investigating

We are currently investigating this issue
Posted Sep 11, 2025 - 03:15 PDT
This incident affected: Person Enrichment APIs (Person Enrichment API, Person Preview Enrichment API, Person Bulk Enrichment API, Person Retrieve API, Person Bulk Retrieve API), Company Enrichment APIs (Company Enrichment API, Bulk Company Enrichment API), Cleaner APIs (Location Cleaner API, Company Cleaner API, School Cleaner API), and Person Search API, Person Identify API, Company Search API, Autocomplete, Job Title Enrichment API, IP Enrichment API, Person Changelog API.