API Returning 500

Incident Report for People Data Labs

Resolved

This incident has been resolved.
Posted Aug 20, 2025 - 07:15 PDT

Update

We are continuing to work on a fix for this issue.
Posted Aug 20, 2025 - 07:07 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 20, 2025 - 06:58 PDT
This incident affected: Person Enrichment APIs (Person Enrichment API, Person Preview Enrichment API, Person Bulk Enrichment API, Person Retrieve API, Person Bulk Retrieve API), Company Enrichment APIs (Company Enrichment API, Bulk Company Enrichment API), Cleaner APIs (Location Cleaner API, Company Cleaner API, School Cleaner API), and Person Search API, Person Identify API, Company Search API, Autocomplete, Job Title Enrichment API, IP Enrichment API, Person Changelog API.