Person Search Errors

Incident Report for People Data Labs

Resolved

This incident has been resolved.
Posted May 29, 2026 - 10:30 PDT

Identified

We are currently experiencing degraded performance with our Person Search endpoint. Engineers are investigating the root cause and will provide an update here soon.
Posted May 29, 2026 - 09:19 PDT
This incident affected: Person Search API.