API Timeouts

Incident Report for People Data Labs

Resolved

The issue has been identified and resolved. We observed that the outage began at approximately 11:20 PM PST on April 17, 2025. We will continue to monitor.
Posted Apr 18, 2025 - 05:36 PDT

Update

We are continuing to investigate this issue.
Posted Apr 18, 2025 - 05:36 PDT

Update

We are investigating an issue affecting all api endpoints where responses are timing out.
Posted Apr 18, 2025 - 05:02 PDT

Investigating

We are currently investigating this issue.
Posted Apr 18, 2025 - 05:02 PDT
This incident affected: Person Search API, Person Identify API, Company Search API, Autocomplete, Skill Enrichment API, Job Title Enrichment API, IP Enrichment API, and Person Changelog API.