Login Flow Issues

Incident Report for People Data Labs

Resolved

We identified an issue that was impacting access to the dashboard for a subset of accounts. We implemented a fix today at 11:45AM PT that ensures impacted users are able to successfully log in and access the API.

If you are experiencing any issues with accessing your account and/or making API calls, please reach out to support@peopledatalabs.com.
Posted Feb 05, 2026 - 11:56 PST

Monitoring

A fix has been implemented and we are monitoring the results
Posted Feb 04, 2026 - 12:17 PST

Identified

The issue has been identified and a fix is being implemented
Posted Feb 04, 2026 - 11:48 PST

Investigating

Users are experiencing issues with logging into the platform and accessing their credits. We are currently investigating the issue.
Posted Feb 04, 2026 - 09:47 PST
This incident affected: API Dashboard (Web Portal, Login Service).